Нет изображения в гаджете популярные сообщения

Модератор: Fleelancer

<<

Иван

Аватара пользователя

Автор темы

Сообщения: 184

Зарегистрирован: 12 апр 2011, 08:51

Благодарил (а): 44 раз.
Поблагодарили: 11 раз.

Сообщение 13 апр 2011, 18:39

Нет изображения в гаджете популярные сообщения

Есть проблема: все картинки постов в гаджете отражаются корректно и даже видео, но почему с одного поста выводится только название без картинки. Так же интересно что при добавлении ссылки этого поста в страницу на facebook, картинка этого поста почему то больше остальных :geek:. Пробовал менять картинку и смотрел код, всё как у всех)
Может кто подскажет что не так?!
Не забывайте говорить спасибо!
<<

Admin

Аватара пользователя

Сообщения: 1450

Зарегистрирован: 21 мар 2011, 15:30

Благодарил (а): 66 раз.
Поблагодарили: 157 раз.

Сообщение 13 апр 2011, 20:00

Re: Нет картинки одного поста в гаджете популярные сообщения

Раз все, как у всех, то как такое может быть?
Значит, действительно, где-то есть проблема. Вообще этот гаджет завязан на Picasa, и проблема может быть, если картинка не так загружена, или, например, загружена через редактор блогов, но я так понимаю, ты не пользуешься редактором. Может дашь ссылку именно на ту статью, в которой проблемная картинка.
<<

Иван

Аватара пользователя

Автор темы

Сообщения: 184

Зарегистрирован: 12 апр 2011, 08:51

Благодарил (а): 44 раз.
Поблагодарили: 11 раз.

Сообщение 13 апр 2011, 20:51

Re: Нет изображения в гаджете популярные сообщения

Я тоже придерживался подобных версий, но нет)))
Можно я ссылку давать не буду (блог светить не хочу), на блоге в виджете всё видно, сейчас два поста так отображаются.
Спасибо за отклик!
Не забывайте говорить спасибо!
<<

johnspade

Аватара пользователя

Сообщения: 194

Зарегистрирован: 11 апр 2011, 21:42

Откуда: Москва

Благодарил (а): 12 раз.
Поблагодарили: 19 раз.

Сообщение 13 апр 2011, 23:44

Re: Нет изображения в гаджете популярные сообщения

Иван писал(а):Есть проблема: все картинки постов в гаджете отражаются корректно и даже видео, но почему с одного поста выводится только название без картинки. Так же интересно что при добавлении ссылки этого поста в страницу на facebook, картинка этого поста почему то больше остальных :geek:. Пробовал менять картинку и смотрел код, всё как у всех)
Может кто подскажет что не так?!

Blogger вообще довольно капризен насчет изображений. Тоже постоянно с ними мучаюсь и не только в Популярных сообщениях.
Нет изображения в гаджете популярные сообщения
<<

Олеся-Fialka

Аватара пользователя

Сообщения: 258

Зарегистрирован: 11 апр 2011, 21:16

Откуда: Киров

Благодарил (а): 9 раз.
Поблагодарили: 16 раз.

Сообщение 15 апр 2011, 13:28

Re: Нет изображения в гаджете популярные сообщения

У меня в популярных сообщениях не отображается картинка, если она вставлена через URL, а не загружена с компьютера.
Такие фото минуют альбомы Пикасса, а потому и не отображаются.

Попутно хотелось бы отметить аналогичную проблему с отображением изображений в рубриках, созданных через скрипт (по мастер-классу блога СЕО-дилетантки).
Если я не ошибаюсь, то сообщения рубрики выводятся из фида, в них все картинки есть, но вот в блоге, при клике на рубрику выводятся список статей и в некоторых изо отсутствую.
Может и правда блоггер капризничает.
"Убивает не падение само по себе, а внезапная остановка на самом дне..." Ричард Б. Риддик "Побег из бухты Мясника"
Мама On-line
<<

Иван

Аватара пользователя

Автор темы

Сообщения: 184

Зарегистрирован: 12 апр 2011, 08:51

Благодарил (а): 44 раз.
Поблагодарили: 11 раз.

Сообщение 15 апр 2011, 13:37

Re: Нет изображения в гаджете популярные сообщения

Олеся-Fialka Спасибо, у меня картинка загружена с ПК. Я пробовал перезалить и другое изображение, пересмотрел код. Но всё та же проблема :?
Не забывайте говорить спасибо!
<<

Admin

Аватара пользователя

Сообщения: 1450

Зарегистрирован: 21 мар 2011, 15:30

Благодарил (а): 66 раз.
Поблагодарили: 157 раз.

Сообщение 15 апр 2011, 13:42

Re: Нет изображения в гаджете популярные сообщения

Олеся-Fialka писал(а):Попутно хотелось бы отметить аналогичную проблему с отображением изображений в рубриках, созданных через скрипт (по мастер-классу блога СЕО-дилетантки).

Да, эта проблема обсуждалась в одной из статей позже, и вот комментарий по поводу решения отображения изображений именно в этом скрипте:
Все дело в строке с кодом:
  Код:
if (img.indexOf('googleusercontent') > -1)


Автор тем самым, оберегал пост от однопиксельных гугл-счётчиков (судя по его комментарию к данному коду) Но с того момента, как гугл для всех загружаемых в блог изображений, стал использовать хранилище googleusercontent, все изображения стали не попадать в блог.
Предыдущие изображения попадали потому что на тот момент использовались другая ссылка без "гуглюзерконтент". Убрав эту строчку у меня всё заработало.
<<

Олеся-Fialka

Аватара пользователя

Сообщения: 258

Зарегистрирован: 11 апр 2011, 21:16

Откуда: Киров

Благодарил (а): 9 раз.
Поблагодарили: 16 раз.

Сообщение 15 апр 2011, 13:47

Re: Нет изображения в гаджете популярные сообщения

Катя, спасибо!
У меня есть еще одна загвоздка с этим скриптом, пока еще "поковыряюсь" с ним, ну уж если не получится, буду взывать к помощи, но это уже другая тема)
"Убивает не падение само по себе, а внезапная остановка на самом дне..." Ричард Б. Риддик "Побег из бухты Мясника"
Мама On-line
<<

Лика_Холодная

Сообщения: 2

Зарегистрирован: 12 апр 2011, 20:18

Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 22 май 2011, 13:37

Re: Нет изображения в гаджете популярные сообщения

А у меня так проблема раз через раз. Все свои посты я пишу через редактор блогов Windows Live Writer, изображения загружаю исключительно с компьютера, так вот в популярных сообщениях в одних постах отображается картинка, в других - нет. Почему такое происходит - непонятно. Было предположение, что это зависит от того, как вставлено изображение (ну, например, вставлено и брошено, или перемещено слева/справа от текста и т.д.), но причем тут это, правильно?
В общем, помогите, пожалуйста, хочется, чтобы картинки видели вместе с названиями!
<<

Fleelancer

Аватара пользователя

Сообщения: 402

Зарегистрирован: 04 май 2011, 18:02

Благодарил (а): 22 раз.
Поблагодарили: 28 раз.

Сообщение 22 май 2011, 13:44

Re: Нет изображения в гаджете популярные сообщения

у меня не отображались картинки, загруженные через редактор и с выравниванием по углам, если ставить по центру и загружать картинки не через редакторы, то всё будет ок. Хотя угловые выравнивания - это очень странно, но у меня именно так
След.

Вернуться в Вопросы от новичков

Кто сейчас на конференции

Зарегистрированные пользователи: нет зарегистрированных пользователей

Работает на phpBB © 2000, 2002, 2005, 2007 phpBB Group. Дизайн ST Software и Blogger Форум. Русская поддержка phpBB
ЧПУ ссылки от phpbb seo